Skip to main content
CVE-2026-108515VulnerabilityPublished

Drupal Drupal core · Cross-site Scripting

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-108515· High

Not known to be exploited · fixed in 12.0.0-beta2 : patch Drupal core soon.

Data as of 30 Oct 2026, 06:59 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 12.0.0-beta2, 11.4.10, 11.3.19 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal core to 12.0.0-beta2, 11.4.10, 11.3.19 or 10.6.19.

Affected software

ProductAffectedFixed in
DrupalDrupal coreAffected
  • >=12.0.0-alpha1 <12.0.0-beta2
Fixed in
  • 12.0.0-beta2
DrupalDrupal coreAffected
  • >=11.4.0 <11.4.10
Fixed in
  • 11.4.10
DrupalDrupal coreAffected
  • >=11.0.0 <11.3.19
Fixed in
  • 11.3.19
DrupalDrupal coreAffected
  • >=8.9.0 <10.6.19
Fixed in
  • 10.6.19

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

References

Community reviews

Loading reviews…