Skip to main content
VulnerabilityPublished

CVE-2026-58037: mediawiki · Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')

Affects mediawikiSource GCVE Database

0
Authoritative record:CVE-2026-58037· High

Not known to be exploited · CVSS 0.0 High.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
0.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10mediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=stonkingOther threatsAffected
  • =1:1.43.8+dfsg-2
  • =1:1.43.9+dfsg-1
  • =1:1.43.9+dfsg-1ubuntu1
Fixed in–
Ubuntu 26.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=resoluteOther threatsAffected
  • 1:1.43.3+dfsg-1 – 1:1.43.8+dfsg-2
5 affected builds
Fixed in–
Ubuntu 25.10mediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=questingOther threatsAffected
  • =1:1.43.1+dfsg-1
  • =1:1.43.1+dfsg-2
  • =1:1.43.3+dfsg-1
Fixed in–
Ubuntu Pro 24.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 1:1.39.4-2 – 1:1.39.7-1ubuntu0.1~esm1
5 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1:1.35.3-1 – 1:1.35.6-1ubuntu0.1~esm1
8 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1:1.31.2-1ubuntu1 – 1:1.31.7-1ubuntu0.1~esm1
9 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to MediaWiki version 1.46.0 or later once available, as the vulnerability affects versions prior to 1.46.0. Until a patch is applied, consider applying input validation or output encoding mitigations specific to the affected components if feasible.

Description

CVE-2026-58037 is a medium severity Cross-site Scripting (XSS) vulnerability in Wikimedia Foundation MediaWiki affecting multiple program files related to language and logging components. It allows improper neutralization of input during web page generation. The vulnerability affects MediaWiki versions prior to 1.46.0, including specific older versions such as 1.45.4, 1.44.6, and 1.43.9. No known exploits in the wild have been reported. The vulnerability was published on July 1, 2026.

References

Community reviews

Loading reviews…