Skip to main content
CVE-2026-7461VulnerabilityPublished

Improper Neutralization of Inputs Used

Source GCVE Database

0
Authoritative record:CVE-2026-7461· High 7.2

Not known to be exploited · CVSS 7.2 High · patch available : patch Amazon ECS Agent soon.

Data as of 27 Oct 2026, 00:31 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
AWSAmazon ECS AgentAffected
  • >=1.47.0 <=1.102.0
Fixed in–
GitHubaws/amazon-ecs-agentpkg:github/aws/amazon-ecs-agentOther threatsAffected
  • =1.47.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the Amazon ECS Agent on Windows to version 1.103.0 or later, which contains the fix for this vulnerability. No other mitigations are specified or required beyond applying this official update.

Description

A command injection vulnerability exists in the FSx Windows File Server volume mounting component of the Amazon ECS Agent on Windows versions prior to 1.103.0. An authenticated attacker with permissions to register ECS task definitions or modify Secrets Manager or SSM Parameter Store credentials can exploit this flaw by crafting a malicious username field in an ECS task definition, leading to execution of shell commands with SYSTEM privileges on the host. This vulnerability is addressed by upgrading to version 1.103.0.

References

Community reviews

Loading reviews…