CVE-2026-2995: GitLab · Improper Neutralization of Script-Related HTML Tags
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.10.1 : patch gitlab soon.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.10.1, 18.9.3, 18.8.7
Exploitation evidence
Disclosed: evidence found.
CVE published 27 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade gitlab to 18.10.1, 18.9.3 or 18.8.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by GitLab. Users should upgrade affected GitLab EE instances to versions 18.8.7, 18.9.3, 18.10.1 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
GitLab EE versions from 15.4 up to but not including 18.8.7, 18.9 up to but not including 18.9.3, and 18.10 up to but not including 18.10.1 contain a vulnerability involving improper sanitization of HTML content. This flaw could allow an authenticated user to add email addresses to targeted user accounts. The issue has been remediated in later versions.