Skip to main content
VulnerabilityPublished

CVE-2026-88028: data query logic · Improper Neutralization of Special Elements

Source GCVE Database

0
Authoritative record:CVE-2026-88028· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 5.11.0 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Laravel MongoDB (PHP) to 5.11.0.

Affected software

ProductAffectedFixed in
MongoDBLaravel MongoDB (PHP)Affected
  • >=1.2.0 <5.11.0
Fixed in
  • 5.11.0

AI-suggested

If you cannot patch yet, review application logic that handles polymorphic relation identifiers and restrict authenticated user input that can influence stored relation identifiers.

Description

A vulnerability in the MongoDB integration for Laravel allows improper neutralization of special elements in polymorphic relation handling. This flaw can cause a caller-supplied relation identifier to be treated as a query condition instead of a literal identifier. An authenticated user able to influence a stored relation identifier may cause the application to return unintended documents. The vulnerability has a CVSS score of 6.5, indicating high severity.

References

Community reviews

Loading reviews…