Skip to main content
VulnerabilityPublished

CVE-2026-34032: Apache HTTP Server · Improper Null Termination, Out-of-bounds Read vulnerability

Source GCVE Database

0
Authoritative record:CVE-2026-34032· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 2.4.67 : update Apache HTTP Server when convenient.

Data as of 27 Oct 2026, 01:22 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • <=2.4.66
Fixed in–

AI-suggested

Users should upgrade Apache HTTP Server to version 2.4.67 or later to remediate this vulnerability. No other mitigation is indicated or required.

Description

CVE-2026-34032 is a medium severity vulnerability in Apache HTTP Server involving improper null termination leading to an out-of-bounds read. This flaw affects versions through 2.4.66. The issue is resolved in version 2.4.67, which users are advised to upgrade to.

References

Community reviews

Loading reviews…