CVE-2026-5816: GitLab · Improper Resolution of Path Equivalence
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 18.11.1 or 18.10.4 soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.11.1, 18.10.4
Exploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade gitlab to 18.11.1 or 18.10.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by GitLab. Users should upgrade to version 18.10.4 or later if on the 18.10 branch, or to version 18.11.1 or later if on the 18.11 branch to remediate this vulnerability.
Description
GitLab CE/EE versions from 18.10.0 up to but not including 18.10.4 and from 18.11.0 up to but not including 18.11.1 contain a vulnerability due to improper path validation. This flaw could allow an unauthenticated user to execute arbitrary JavaScript in another user's browser session. The issue has been remediated in versions 18.10.4 and 18.11.1.