Skip to main content
CVE-2024-7404VulnerabilityPublished Updated

CVE-2024-7404: Improper Restriction of Rendered UI Layers or Frames in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.5.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.5.2, 17.4.4, 17.3.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 17.5.2, 17.4.4 or 17.3.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.2.0 <17.3.7
  • >=17.4.0 <17.4.4
  • >=17.5.0 <17.5.2
Fixed in
  • 17.3.7
  • 17.4.4
  • 17.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab CE/EE instances to versions 17.3.7, 17.4.4, or 17.5.2 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

GitLab CE/EE versions starting from 17.2 up to but excluding 17.3.7, from 17.4 up to but excluding 17.4.4, and from 17.5 up to but excluding 17.5.2 contain a vulnerability that could allow an attacker with full API access via the Device OAuth flow to exploit improper restriction of rendered UI layers or frames. This vulnerability has a medium severity rating and a patch is available.

References

Community reviews

Loading reviews…