CVE-2025-0362: Improper Restriction of Rendered UI Layers or Frames in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.10.4 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.10.4
Exploitation evidence
Disclosed: evidence found.
CVE published 12 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.10.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to version 17.10.4 or later to remediate the issue. Since this is not a cloud service, manual patching by administrators is required.
Description
GitLab CE/EE contains a vulnerability (CVE-2025-0362) affecting versions from 7.7 up to but not including 17.10.4. This flaw involves improper restriction of rendered UI layers or frames, which could allow an attacker to trick users into unintentionally authorizing sensitive actions. The issue is medium severity and has an available patch.