Skip to main content
VulnerabilityPublished

CVE-2026-90885: Improper Restriction of XML External Entity Reference vulnerability in Apache Camel Saxon component

Source GCVE Database

0
Authoritative record:CVE-2026-90885· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.22.2 or 4.18.5 soon.

Data as of 26 Oct 2026, 16:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.22.2, 4.18.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.22.2 or 4.18.5.

Affected software

ProductAffectedFixed in
Apache Camelorg.apache.camel:camel-saxonAffected
  • >=4.19.0 <4.22.2
Fixed in
  • 4.22.2
Apache Camelorg.apache.camel:camel-saxonAffected
  • >=4.0.0 <4.18.5
Fixed in
  • 4.18.5
MavenApache Software Foundation/org.apache.camel:camel-saxonpkg:maven/Apache Software Foundation/org.apache.camel:camel-saxonOther threatsAffected
  • >=4.0.0 <4.18.5
  • >=4.19.0 <4.22.2
Fixed in
  • 4.18.5
  • 4.22.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Camel to version 4.23.0, or if on the 4.22.x stream, upgrade to 4.22.2, or if on the 4.18.x stream, upgrade to 4.18.5. Versions prior to these fixed releases are vulnerable and unsupported. For deployments that cannot upgrade immediately, do not evaluate XQuery over message bodies that are already javax.xml.transform.Source when the XML originates from untrusted sources. Alternatively, configure the xquery endpoint or language to use a Saxon Configuration with parse options that disable DOCTYPE declarations and external entity resolution, as done in the fixed releases.

Description

CVE-2026-90885 is an XML External Entity (XXE) vulnerability in the Apache Camel Saxon component affecting versions from 4.0.0 before 4.18.5 and from 4.19.0 before 4.22.2. The vulnerability arises because the default Saxon Configuration used by the XQueryBuilder allows DOCTYPE declarations and external entity resolution when the message body is already a javax.xml.transform.Source. This can lead to disclosure of files readable by the Camel process and can cause the process to issue network requests to attacker-controlled hosts. Fixed versions are 4.18.5, 4.22.2, and 4.23.0.

References

Community reviews

Loading reviews…