Skip to main content
VulnerabilityPublished

CVE-2026-118559: Drupal Commerce Stripe · Improper Verification of Cryptographic Signature Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118559· High

Not known to be exploited : upgrade to 2.2.3 or 1.4 soon.

Data as of 30 Oct 2026, 07:15 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.2.3, 1.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Commerce Stripe to 2.2.3 or 1.4.

Affected software

ProductAffectedFixed in
DrupalCommerce StripeAffected
  • >=2.0.0 <2.2.3
Fixed in
  • 2.2.3
DrupalCommerce StripeAffected
  • <1.4
Fixed in
  • 1.4

Description

A vulnerability in Drupal Commerce Stripe allows improper verification of cryptographic signatures, leading to potential signature spoofing. This affects Commerce Stripe versions from 0.0.0 to 1.4 and from 2.0.0 to 2.2.3.

References

Community reviews

Loading reviews…