Skip to main content
VulnerabilityPublished Updated

CVE-2025-2866: LibreOffice · Improper Verification of Cryptographic Signature Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-2866· Low 2.4

Not known to be exploited · CVSS 2.4 Low · fixed in 25.2.2 : update affected systems when convenient.

Data as of 30 Oct 2026, 01:34 UTC

CVSS 4.0 base score
2.4Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Document Fdn.)CVSS 4.02.4
Patch
Available – fixed in 25.2.2, 24.8.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

LibreOffice has released fixed versions 24.8.6 and 25.2.2 that address this vulnerability. Users should upgrade to these or later versions to remediate the issue. No other mitigation or temporary workaround is indicated in the available data.

Description

A cryptographic signature verification flaw in LibreOffice allows invalid PDF signatures using adbe.pkcs7.sha1 to be accepted as valid. This vulnerability affects LibreOffice versions from 24.8 up to but not including 24.8.6, and from 25.2 up to but not including 25.2.2. The issue could enable PDF signature spoofing due to improper validation.

References

Community reviews

Loading reviews…