Skip to main content
VulnerabilityPublished Updated

CVE-2026-58062: Bouncycastle · In Bouncy Castle for Java before 1.85, Stapled OCSP response accepted without binding to the checked certificate

Affects bouncycastleSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-58062· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical · fixed in 1.85 : patch bouncycastle as a priority.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.85, 2.73.12, 2.1.3 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade org.bouncycastle/bcprov-jdk15on to 1.85; org.bouncycastle/bcpkix-jdk15on to 2.73.12; org.bouncycastle/bc-fips to 2.1.3 or 2.0.2.

Affected software

ProductAffectedFixed in
Ubuntu Pro 16.04 LTSbouncycastlepkg:deb/ubuntu/bouncycastle?arch=source&distro=esm-apps/xenialOther threatsAffected
  • =1.49+dfsg-3ubuntu1
  • =1.51-4ubuntu1
  • =1.51-4ubuntu1+esm1
Fixed in–
Ubuntu Pro 18.04 LTSbouncycastlepkg:deb/ubuntu/bouncycastle?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 1.57-1 – 1.59-1ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSbouncycastlepkg:deb/ubuntu/bouncycastle?arch=source&distro=esm-apps/focalOther threatsAffected
  • =1.61-1
  • =1.61-1ubuntu0.1~esm1
Fixed in–
Ubuntu Pro 22.04 LTSbouncycastlepkg:deb/ubuntu/bouncycastle?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1.68-2 – 1.68-5ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSbouncycastlepkg:deb/ubuntu/bouncycastle?arch=source&distro=esm-apps/nobleOther threatsAffected
  • =1.72-2
  • =1.77-1
  • =1.77-1ubuntu0.1~esm1
Fixed in–
Ubuntu 26.10bouncycastlepkg:deb/ubuntu/bouncycastle?arch=source&distro=stonkingOther threatsAffected
  • =1.80-3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until then, consider disabling OCSP stapling verification or using alternative certificate validation methods if feasible.

Description

Package akhq version 0.27.1-r5 fixes 27 vulnerabilities: CVE-2026-58062, CVE-2026-59638, CVE-2026-59646, CVE-2026-12802, CVE-2026-59639...

References

Community reviews

Loading reviews…