In Eclipse Mnestix Browser versions 1.2.0 up until but excluding 2.3.0 it was possible for an unauthenticated attacker
Source GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2.3.0 soon.
Data as of 3 Nov 2026, 13:14 UTC
Thin evidence
One scorer or none| CNA (eclipse) | CVSS 4.0 | 8.8 |
|---|
- Patch
- Available – fixed in 2.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Eclipse Mnestix and org.eclipse/mnestix-browser to 2.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eclipse FoundationEclipse Mnestix | Affected
| Fixed in
|
Mavenorg.eclipse/mnestix-browserpkg:maven/org.eclipse/mnestix-browserOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict network access to the affected versions and monitor for unauthorized activity related to Infrastructure settings and backend calls.
Description
Eclipse Mnestix Browser versions from 1.2.0 up to but excluding 2.3.0 contain a vulnerability that allows unauthenticated attackers to perform privileged actions. These actions include changing Infrastructure settings and invoking the connected authenticated Mnestix AAS Generator backend, which should only be accessible to authorized users.