Skip to main content
CVE-2026-40687VulnerabilityPublished

In Exim before 4.99.2, when the SPA authentication driver is used with an adversarial SPA resource, there can be an

Source GCVE Database

0
Authoritative record:CVE-2026-40687· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium.

Data as of 27 Oct 2026, 00:35 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
Exim before 4.99.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

A fixed version 4.99.2 or later addresses this issue. Until patched, avoid using the SPA authentication driver with untrusted SPA resources.

Description

A vulnerability in Exim before version 4.99.2 involving the SPA authentication driver can cause an out-of-bounds write or leak data from uninitialized heap memory when interacting with a malicious SPA resource. This may crash the connection or expose sensitive data.

References

Community reviews

Loading reviews…