CVE-2025-64457: In JetBrains dotTrace before 2025.2.5 local privilege escalation possible via race condition
Source GCVE Database
Not known to be exploited · CVSS 4.2 Medium · fixed in 2025.2.5 : update JetBrains dotTrace when convenient.
Data as of 7 Nov 2026, 17:21 UTC
- Affects
- JetBrains dotTrace before 2025.2.5
- Patch
- Available – fixed in 2025.2.5
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
AI-suggested
The vulnerability affects JetBrains dotTrace versions before 2025.2.5. Users should upgrade to version 2025.2.5 or later once available. Since no explicit patch links or vendor advisory are provided, confirm patch availability from JetBrains official sources. No cloud service remediation applies as this is a local software product.
Description
JetBrains dotTrace versions prior to 2025.2.5 contain a local privilege escalation vulnerability due to a race condition. This flaw could allow a local attacker with limited privileges to escalate their rights on the affected system. The vulnerability has a medium severity rating with a CVSS score of 4.2. No public exploits or patches are explicitly referenced in the provided data.