Skip to main content
CVE-2026-123310VulnerabilityPublished

In JetBrains IntelliJ IDEA before 2026.3 kotlin scripts could trigger dependency downloads from arbitrary repositories

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123310· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium : upgrade to 2026.3 when convenient.

Data as of 6 Nov 2026, 13:35 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JetBrains)CVSS 3.15.4
Patch
Available – fixed in 2026.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade IntelliJ IDEA to 2026.3.

Affected software

ProductAffectedFixed in
JetBrainsIntelliJ IDEAAffected
  • <2026.3
Fixed in
  • 2026.3

AI-suggested

If you cannot patch yet, users should avoid opening untrusted projects containing Kotlin scripts or restrict network access for the IDE to prevent unauthorized dependency downloads.

Description

A vulnerability in JetBrains IntelliJ IDEA before version 2026.3 allows Kotlin scripts in untrusted projects to trigger dependency downloads from arbitrary repositories. This could lead to unintended network activity and potential exposure to malicious dependencies.

References

Community reviews

Loading reviews…