In JetBrains IntelliJ IDEA, PyCharm, PhpStorm, RubyMine and WebStorm before 2026.3, 2026.2.4, 2026.1.5.1, and
Source GCVE Database
Not known to be exploited · CVSS 8.0 High · fixed in 2026.2.4 : patch IntelliJ IDEA soon.
Data as of 30 Oct 2026, 20:03 UTC
Thin evidence
One scorer or none| CNA (JetBrains) | CVSS 3.1 | 8.0 |
|---|
- Patch
- Available – fixed in 2026.2.4, 2026.1.5.1, 2025.3.6.2 +13
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
| JetBrainsPyCharm | Affected
| Fixed in
|
| JetBrainsPyCharm | Affected
| Fixed in
|
| JetBrainsPyCharm | Affected
| Fixed in
|
AI-suggested
Users should upgrade affected JetBrains IDEs to versions 2026.3, 2026.2.4 (or later minor releases), 2026.1.5.x, and 2025.3.x as specified for each product to ensure the embedded browser no longer trusts revoked intermediate certificates. Since the vulnerability is fixed in these versions, applying the official updates is the recommended remediation. No additional mitigation steps are indicated.
Description
A vulnerability identified as CVE-2026-118696 affects multiple JetBrains IDEs including IntelliJ IDEA, PyCharm, PhpStorm, RubyMine, WebStorm, GoLand, Rider, CLion, DataGrip, RustRover, and DataSpell in versions prior to specified 2026.x and 2025.x releases. The issue involves the embedded browser trusting revoked intermediate certificates, which can lead to a high-impact security breach. The vulnerability has a high CVSS score of 8.0, indicating significant confidentiality and integrity impact with no known exploitation in the wild at this time.
References
- nvd.nist.gov/vuln/detail/CVE-2026-118696 (opens in a new tab)
- blog.jetbrains.com/security/2026/10/compromised-emudhra-certificates-ides (opens in a new tab)
- bugzilla.mozilla.org/show_bug.cgi?id=2083449 (opens in a new tab)
- emudhra.com/en/post/certificate-security-incident (opens in a new tab)
- jetbrains.com/privacy-security/issues-fixed (opens in a new tab)