Skip to main content
VulnerabilityPublished Updated

CVE-2026-41526: In KDE KCoreAddons before 6.25, KShell::quoteArgs is intended to safely quote arguments so that they

Affects kcoreaddonsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-41526· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.24.0-0ubuntu1.1 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.24.0-0ubuntu1.1
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu kf6-kcoreaddons package to 6.24.0-0ubuntu1.1.

Affected software

ProductAffectedFixed in
Ubuntu 26.10kcoreaddonspkg:deb/ubuntu/kcoreaddons?arch=source&distro=stonkingOther threatsAffected
  • =5.116.0-1ubuntu1
  • =5.116.0-2
  • =5.116.0-4
Fixed in–
Ubuntu 26.04 LTSkcoreaddonspkg:deb/ubuntu/kcoreaddons?arch=source&distro=resoluteOther threatsAffected
  • =5.116.0-1ubuntu1
Fixed in–
Ubuntu 26.04 LTSkf6-kcoreaddonspkg:deb/ubuntu/kf6-kcoreaddons?arch=source&distro=resoluteOther threatsAffected
  • <6.24.0-0ubuntu1.1
Fixed in
  • 6.24.0-0ubuntu1.1
Ubuntu 25.10kcoreaddonspkg:deb/ubuntu/kcoreaddons?arch=source&distro=questingOther threatsAffected
  • =5.116.0-0ubuntu1
  • =5.116.0-1ubuntu1
Fixed in–
Ubuntu 25.10kf6-kcoreaddonspkg:deb/ubuntu/kf6-kcoreaddons?arch=source&distro=questingOther threatsAffected
  • 6.12.0-0ubuntu1 – 6.17.0-0ubuntu1
6 affected builds
Fixed in–
Ubuntu 24.04 LTSkcoreaddonspkg:deb/ubuntu/kcoreaddons?arch=source&distro=nobleOther threatsAffected
  • 5.110.0-0ubuntu1 – 5.115.0-0ubuntu5
8 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patch by updating to KCoreAddons version 6.24.0-0ubuntu1.1 or later as provided in the Ubuntu security notice USN-8857-1. A standard system update will apply the necessary fixes. No additional mitigation steps are required once the update is applied.

Description

KDE KCoreAddons before version 6.25 contains a vulnerability in the KShell::quoteArgs function, which is intended to safely quote shell command arguments. The function does not properly handle shell metacharacters, allowing an attacker to escape the shell context. This flaw affects applications that rely on this method to process user input securely, potentially enabling arbitrary command execution. The issue is fixed in version 6.24.0-0ubuntu1.1.

References

Community reviews

Loading reviews…