Skip to main content
CVE-2025-32414VulnerabilityPublished Updated

In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur in the Python API (Python bindings) because of an incorrect return value

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-32414· Medium 5.6

Not known to be exploited · CVSS 5.6 Medium : upgrade to 2.14.2 or 2.13.8 when convenient.

Data as of 29 Oct 2026, 22:52 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.15.6
Patch
Available – fixed in 2.14.2, 2.13.8
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Debian debian/libxml2 package to 2.14.2 or 2.13.8.

Affected software

ProductAffectedFixed in
Debiandebian/libxml2pkg:deb/debian/libxml2Other threatsAffected
  • <2.13.8
  • >=2.14.0 <2.14.2
  • =2.14.0
Fixed in
  • 2.13.8
  • 2.14.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur in the Python API (Python bindings) because of an incorrect return value. This occurs in xmlPythonFileRead and xmlPythonFileReadRaw because of a difference between bytes and characters.

References

Community reviews

Loading reviews…