Skip to main content
VulnerabilityPublished

CVE-2026-66089: In openEQUELLA before 2026.1, the SOAP API parses XML supplied in the stopEdit operation with a

Affects openEQUELLASource GCVE Database

0
Compare
Authoritative record:CVE-2026-66089· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2026.1 when convenient.

Data as of 29 Oct 2026, 04:28 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
openEQUELLA before 2026.1
Patch
Available – fixed in 2026.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:L/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openequella/openEQUELLA to 2026.1.

Affected software

ProductAffectedFixed in
GitHubopenequella/openEQUELLApkg:github/openequella/openEQUELLAOther threatsAffected
  • <2026.1
Fixed in
  • 2026.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability affects versions before 2026.1, upgrading to version 2026.1 or later is implied to resolve the issue. If you cannot patch yet, restrict access to the SOAP API's stopEdit operation to trusted users only and monitor for suspicious activity related to XML processing. Check the vendor advisory for official remediation guidance.

Description

openEQUELLA versions before 2026.1 have a vulnerability in the SOAP API's stopEdit operation where XML parsing resolves external entities. This flaw enables attackers to read arbitrary files accessible by the service or perform server-side request forgery (SSRF). The vulnerability has a medium severity rating with a CVSS score of 6.1.

References

Community reviews

Loading reviews…