Skip to main content
VulnerabilityPublished

CVE-2026-66092: In openEQUELLA before 2026.2, the pre-login notice is stored as HTML and rendered on the legacy logon

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-66092· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium : upgrade to 2026.2 when convenient.

Data as of 29 Oct 2026, 04:28 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (MON-CSIRT)CVSS 4.04.8
Patch
Available – fixed in 2026.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openEQUELLA and openequella/openEQUELLA to 2026.2.

Affected software

ProductAffectedFixed in
Apereo FoundationopenEQUELLAAffected
  • >=2019.1 <2026.2
Fixed in
  • 2026.2
GitHubopenequella/openEQUELLApkg:github/openequella/openEQUELLAOther threatsAffected
  • >=2019.1 <2026.2
Fixed in
  • 2026.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in openEQUELLA version 2026.2. Users should upgrade to this version or later to remediate the vulnerability. Additionally, ensure that the EDIT_SYSTEM_SETTINGS permission is not granted to guest or Everyone users to prevent unauthenticated exploitation. Since this is not a cloud service, remediation depends on applying the vendor's patch or upgrade.

Description

openEQUELLA versions prior to 2026.2 have a stored cross-site scripting (XSS) vulnerability in the pre-login notice feature. The notice is stored as HTML and rendered on the legacy login page without proper encoding or sanitization. Users with the EDIT_SYSTEM_SETTINGS permission can inject arbitrary scripts via the pre-login notice API endpoint. If this permission is granted to guest or Everyone users, unauthenticated exploitation is possible.

References

Community reviews

Loading reviews…