Skip to main content
VulnerabilityPublished Updated

CVE-2025-38204: Linux kernel · jfs: fix array-index-out-of-bounds read in add_missing_indices

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-38204· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1092.99~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1092.99~20.04.1, 5.15.0-1096.105~20.04.1, 5.15.0-1114.123~20.04.1 +33
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-136.136?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-9.9 – 6.8.0-136.136
53 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1060.63?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1008.8 – 6.8.0-1060.63
48 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14@6.14.0-1015.15~24.04.1?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1015.15~24.04.1
Fixed in
  • 6.14.0-1015.15~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1062.69?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1007.7 – 6.8.0-1062.69
39 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11@6.11.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and has been released as part of a comprehensive Linux kernel security update. Users and administrators should apply the updated kernel packages provided by their Linux distribution vendors, such as the Ubuntu security notice USN-7774-1. No additional mitigation steps are required beyond applying the official fix.

Description

A vulnerability in the Linux kernel's JFS file system was fixed to prevent an array-index-out-of-bounds read in the add_missing_indices function. The flaw involved improper bounds checking of an index that could range from 0 to 127, which was not correctly enforced, potentially leading to memory errors. The fix adds a boundary check and returns an error if the check fails, preventing improper memory access. This issue was addressed in a broader Linux kernel security update covering multiple subsystems.

References

Community reviews

Loading reviews…