Skip to main content
VulnerabilityPublished Updated

CVE-2025-40118: Linux kernel · scsi: pm80xx: Fix array-index-out-of-of-bounds on rmmod

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1110.119~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1110.119~20.04.1, 5.15.0-1100.109~20.04.1, 5.15.0-1100.107~20.04.2 +2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
linux-hwe-edgeAffected
  • <5.15.0-1100.107~20.04.2
  • <5.15.0-1110.119~20.04.1
  • <5.15.0-1100.109~20.04.1
  • <5.15.0-170.180~20.04.3
  • <5.15.0-1094.97~20.04.1
Fixed in
  • 5.15.0-1100.107~20.04.2
  • 5.15.0-1110.119~20.04.1
  • 5.15.0-1100.109~20.04.1
  • 5.15.0-170.180~20.04.3
  • 5.15.0-1094.97~20.04.1

AI-suggested

A fix has been implemented in the Linux kernel source to correct the array indexing logic in the pm80xx driver. Users should update to a kernel version that includes the commit f7b705c238d1 or later, which addresses this issue. Since this is a kernel vulnerability, applying the official kernel update from the vendor or distribution is the recommended remediation.

Description

In the Linux kernel, the following vulnerability has been resolved: scsi: pm80xx: Fix array-index-out-of-of-bounds on rmmod Since commit f7b705c238d1 ("scsi: pm80xx: Set phy_attached to zero when device is gone") UBSAN reports: UBSAN: array-index-out-of-bounds in drivers/scsi/pm8001/pm8001_sas.c:786:17 index 28 is out of range for type 'pm8001_phy [16]' on rmmod when using an expander. For a direct attached device, attached_phy contains the local phy id. For a device behind an expander, attached_phy contains the remote phy id, not the local phy id. I.e. while pm8001_ha will have pm8001_ha->chip->n_phy local phys, for a device behind an expander, attached_phy can be much larger than pm8001_ha->chip->n_phy (depending on the amount of phys of the expander). E.g. on my system pm8001_ha has 8 phys with phy ids 0-7. One of the ports has an expander connected. The expander has 31 phys with phy ids 0-30. The pm8001_ha->phy array only contains the phys of the HBA. It does not contain the phys of the expander. Thus, it is wrong to use attached_phy to index the pm8001_ha->phy array for a device behind an expander. Thus, we can only clear phy_attached for devices that are directly attached.

References

Community reviews

Loading reviews…