Skip to main content
VulnerabilityPublished Updated

CVE-2025-40300: Linux kernel · x86/vmscape: Add conditional IBPB mitigation

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 3.13.0-208.259 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.13.0-208.259, 4.4.0-1149.155, 4.15.0-1194.209~14.04.1 +113
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-87.88
Fixed in
  • 6.8.0-87.88
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1042.44
Fixed in
  • 6.8.0-1042.44
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1016.16~24.04.1
Fixed in
  • 6.14.0-1016.16~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1044.50
Fixed in
  • 6.8.0-1044.50
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating the Linux kernel packages to the fixed versions as specified in the Ubuntu security advisories USN-7850-1 and USN-7853-1. After applying the update, a system reboot is required to activate the mitigation. Due to an ABI change in the kernel, all third-party kernel modules must be recompiled and reinstalled. Users should follow vendor instructions carefully to ensure full remediation. No additional mitigation is required beyond applying the official patches and rebooting. Ubuntu Pro users can obtain fixes via the Legacy Support add-on or standard updates.

Description

CVE-2025-40300, known as VMSCAPE, is a vulnerability in the Linux kernel affecting certain processors where insufficient branch predictor isolation exists between a guest virtual machine and a userspace hypervisor. This flaw could allow an attacker in a guest VM to potentially expose sensitive information from the host operating system. The vulnerability is mitigated by conditionally issuing an Indirect Branch Prediction Barrier (IBPB) after VMexit before returning to userspace, although this may introduce overhead for workloads frequently switching between hypervisor and userspace. The issue has been addressed in multiple Linux kernel versions with patches available. Users are advised to update their Linux kernel packages and reboot to apply the fixes. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary.

References

Community reviews

Loading reviews…