Skip to main content
VulnerabilityPublished Updated

CVE-2026-55223: In versions prior to 0.14.0, c3p0

Affects c3p0Source GCVE Database

0
Authoritative record:CVE-2026-55223· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in 0.9.1.2-9+deb8u1ubuntu0.16.04.1~esm2 : update c3p0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.1.2-9+deb8u1ubuntu0.16.04.1~esm2, 0.9.1.2-9+deb8u1ubuntu0.18.04.1+esm1, 0.9.1.2-10ubuntu0.20.04.1+esm1 +3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10c3p0pkg:deb/ubuntu/c3p0?arch=source&distro=stonkingOther threatsAffected
  • =0.9.1.2-11
Fixed in–
Ubuntu Pro 26.04 LTSc3p0pkg:deb/ubuntu/c3p0?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <0.9.1.2-11ubuntu0.1~esm1
Fixed in
  • 0.9.1.2-11ubuntu0.1~esm1
Ubuntu 25.10c3p0pkg:deb/ubuntu/c3p0?arch=source&distro=questingOther threatsAffected
  • =0.9.1.2-10ubuntu2
Fixed in–
Ubuntu Pro 24.04 LTSc3p0pkg:deb/ubuntu/c3p0?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <0.9.1.2-10ubuntu2+esm1
Fixed in
  • 0.9.1.2-10ubuntu2+esm1
Ubuntu Pro 22.04 LTSc3p0pkg:deb/ubuntu/c3p0?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <0.9.1.2-10ubuntu1+esm1
Fixed in
  • 0.9.1.2-10ubuntu1+esm1
Ubuntu Pro 20.04 LTSc3p0pkg:deb/ubuntu/c3p0?arch=source&distro=esm-apps/focalOther threatsAffected
  • <0.9.1.2-10ubuntu0.20.04.1+esm1
Fixed in
  • 0.9.1.2-10ubuntu0.20.04.1+esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should update to c3p0 version 0.14.0 or later. For Ubuntu users, applying the security updates provided in the Ubuntu Security Notice USN-8642-1 will remediate the issue. The fixed package versions include libc3p0-java 0.9.1.2-9+deb8u1ubuntu0.16.04.1~esm2 and later for supported Ubuntu releases. Standard system updates or Ubuntu Pro via ESM Apps will apply these fixes. No additional mitigation steps are required beyond applying the official patches.

Description

c3p0 versions prior to 0.14.0 contain a deserialization vulnerability that can be exploited when used with certain other libraries. This vulnerability allows attackers to craft malicious serialized DataSource objects that trigger unsafe property lookups during JavaBean property auto-resolution, potentially invoking vulnerable JDBC drivers. The issue requires a susceptible DataSource or ConnectionPoolDataSource, a vulnerable JDBC driver on the classpath, and a deserialization context that auto-resolves bean properties. The vulnerability has been fixed in version 0.14.0 and in specific patched Ubuntu package versions.

References

Community reviews

Loading reviews…