Skip to main content
CVE-2026-123660VulnerabilityPublished

In Vulnerability-Lookup 5.5.1 up to but not including 6.4.1, a signed-in user could make the server allocate memory

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123660· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 6.4.1 when convenient.

Data as of 6 Nov 2026, 10:34 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (CIRCL)CVSS 4.05.3
Patch
Available – fixed in 6.4.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade vulnerability-lookup and vulnerability-lookup/vulnerability-lookup to 6.4.1.

Affected software

ProductAffectedFixed in
vulnerability-lookupvulnerability-lookupAffected
  • >=5.5.1 <6.4.1
Fixed in
  • 6.4.1
GitHubvulnerability-lookup/vulnerability-lookuppkg:github/vulnerability-lookup/vulnerability-lookupOther threatsAffected
  • >=5.5.1 <6.4.1
Fixed in
  • 6.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Vulnerability-Lookup version 6.4.1 or later, which implements caps on format specifier sizes, limits on rendered template length, and nesting depth restrictions to prevent excessive memory allocation and recursion errors. These mitigations effectively address the vulnerability. No additional action is required if already running version 6.4.1 or newer.

Description

Vulnerability-Lookup versions 5.5.1 up to but not including 6.4.1 contain a flaw where signed-in users can cause excessive memory allocation via webhook notification payload templates. The issue arises because format specifiers in placeholders are passed directly to Python's string formatting, allowing creation of very large strings. This can lead to denial of service by exhausting memory resources of web workers or the notification daemon. Version 6.4.1 introduces limits on format specifier sizes, template length, and nesting depth to mitigate the issue.

References

Community reviews

Loading reviews…