CVE-2024-8970: GitLab · Incorrect Authorization
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.4.2 : patch gitlab soon.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.4.2, 17.3.5, 17.2.9
Exploitation evidence
Disclosed: evidence found.
CVE published 15 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.4.2, 17.3.5 or 17.2.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade to GitLab versions 17.2.9, 17.3.5, or 17.4.2 or later to remediate this vulnerability. Applying these official fixes will prevent exploitation of this incorrect authorization issue.
Description
GitLab CE/EE versions from 11.6 up to but not including 17.2.9, from 17.3 up to but not including 17.3.5, and from 17.4 up to but not including 17.4.2 contain an authorization flaw. This vulnerability allows an attacker to trigger a pipeline as another user under certain conditions. The issue has been addressed in the fixed versions 17.2.9, 17.3.5, and 17.4.2. No known exploits are reported in the wild at this time.