Skip to main content
VulnerabilityPublished Updated

CVE-2024-9623: GitLab · Incorrect Authorization

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.4.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 08:30 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.4.2, 17.3.5, 17.2.9

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.4.2, 17.3.5 or 17.2.9.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=8.16.0 <17.2.9
  • >=17.3.0 <17.3.5
  • >=17.4.0 <17.4.2
Fixed in
  • 17.2.9
  • 17.3.5
  • 17.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab CE/EE instances to versions 17.2.9 or later for the 8.16+ to 17.2.9 range, 17.3.5 or later for the 17.3+ to 17.3.5 range, and 17.4.2 or later for the 17.4+ to 17.4.2 range to remediate this issue.

Description

A vulnerability in GitLab CE/EE allows deploy keys to push changes to repositories that have been archived. This issue affects multiple version ranges starting from 8.16 up to versions prior to 17.2.9, 17.3 prior to 17.3.5, and 17.4 prior to 17.4.2. The flaw permits unauthorized write access to archived repositories, which are typically intended to be read-only.

References

Community reviews

Loading reviews…