Skip to main content
VulnerabilityPublished Updated

CVE-2024-9693: GitLab · Incorrect Authorization

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.5.2 : patch gitlab soon.

Data as of 26 Oct 2026, 09:08 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.5.2, 17.4.4, 17.3.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.5.2, 17.4.4 or 17.3.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.0.0 <17.3.7
  • >=17.4.0 <17.4.4
  • >=17.5.0 <17.5.2
Fixed in
  • 17.3.7
  • 17.4.4
  • 17.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GitLab CE/EE to versions 17.3.7, 17.4.4, or 17.5.2 or later. Since a patch is available, remediation should be performed promptly to prevent unauthorized access. No additional vendor advisory states that no action is required.

Description

A vulnerability in GitLab CE/EE allows incorrect authorization that could enable unauthorized access to the Kubernetes agent in a cluster under specific configurations. This affects multiple version ranges starting from 16.0 up to versions prior to 17.3.7, 17.4 up to prior to 17.4.4, and 17.5 up to prior to 17.5.2. A patch is available to address this issue.

References

Community reviews

Loading reviews…