CVE-2025-0652: GitLab · Incorrect Authorization
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.9.2 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.9.2
Exploitation evidence
Disclosed: evidence found.
CVE published 15 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.9.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches available for GitLab versions 17.7.7, 17.8.5, and 17.9.2 or later to remediate this incorrect authorization vulnerability. Since a patch is available, updating to a fixed version is the recommended mitigation.
Description
A vulnerability in GitLab EE/CE versions from 16.9 up to but not including 17.9.2 allows unauthorized users to access confidential internal information. This issue affects multiple version ranges and has a medium severity rating. A patch is available to address this incorrect authorization flaw.