CVE-2025-11865: GitLab · Incorrect Authorization
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.5.2 : update gitlab when convenient.
Data as of 26 Oct 2026, 07:57 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.5.2, 18.4.4, 18.3.6
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade gitlab to 18.5.2, 18.4.4 or 18.3.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading GitLab EE to version 18.3.6, 18.4.4, or 18.5.2 or later. Applying these updates will remediate the incorrect authorization vulnerability and prevent attackers from removing Duo flows of other users.
Description
GitLab EE versions 18.1 up to but not including 18.3.6, 18.4 up to but not including 18.4.4, and 18.5 up to but not including 18.5.2 contain an authorization vulnerability. This flaw could allow an attacker to remove Duo authentication flows of another user under certain conditions. A patch is available to address this issue.