CVE-2025-11971: GitLab · Incorrect Authorization
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.5.1 : update gitlab when convenient.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.5.1, 18.4.3, 18.3.5
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade gitlab to 18.5.1, 18.4.3 or 18.3.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected GitLab EE instances to versions 18.3.5, 18.4.3, or 18.5.1 or later to apply the official fix. Since this is not a cloud service, administrators must apply the patch manually.
Description
An incorrect authorization vulnerability in GitLab Enterprise Edition allows an authenticated attacker to trigger unauthorized pipeline executions by manipulating commits. This issue affects GitLab versions from 10.6 up to but not including 18.3.5, versions 18.4.0 up to but not including 18.4.3, and versions 18.5.0 up to but not including 18.5.1. A fix is available in versions 18.3.5, 18.4.3, and 18.5.1.