CVE-2025-2242: GitLab · Incorrect Authorization
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.10.1 soon.
Data as of 26 Oct 2026, 09:15 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.10.1
Exploitation evidence
Disclosed: evidence found.
CVE published 29 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in GitLab versions 17.8.6, 17.9.3, and 17.10.1. Users should upgrade affected GitLab instances to one of these versions or later to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official patches.
Description
An improper access control vulnerability in GitLab CE/EE allows users who were previously instance administrators but have been downgraded to regular users to retain elevated privileges on groups and projects. This affects versions from 17.4 up to but not including 17.10.1. The issue has been addressed in versions 17.8.6, 17.9.3, and 17.10.1.