Skip to main content
VulnerabilityPublished

CVE-2026-107255: Drupal Restrict route by IP · Incorrect Authorization Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-107255· High

Not known to be exploited : upgrade to 2.0.1 or 1.3.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.0.1, 1.3.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Restrict route by IP to 2.0.1 or 1.3.1.

Affected software

ProductAffectedFixed in
DrupalRestrict route by IPAffected
  • >=2.0.0 <2.0.1
Fixed in
  • 2.0.1
DrupalRestrict route by IPAffected
  • <1.3.1
Fixed in
  • 1.3.1

Description

Incorrect Authorization vulnerability in Drupal Restrict route by IP allows Forceful Browsing. This issue affects Restrict route by IP versions: from 0.0.0 to 1.3.1, from 2.0.0 to 2.0.1.

References

Community reviews

Loading reviews…