Skip to main content
VulnerabilityPublished

CVE-2026-84177: Apache Wicket: a file path · Incorrect Behavior Order

Affects wicket-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-84177· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in 8.20.0 : update wicket-core when convenient.

Data as of 2 Nov 2026, 01:00 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.06.3
Patch
Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 or later, which contain fixes for this vulnerability. No other configuration changes or mitigations are indicated. Running in deployment mode does not prevent the issue. Users of unsupported versions (7.x or older) should upgrade to a supported and fixed version.

Description

Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0 contain a vulnerability where file path validation occurs before appending style, variation, and locale attributes. This allows an attacker to access component markup templates if the component class name contains underscores and no shorter class name exists. The exposure is limited to developer-authored HTML templates within the component's package and is read-only. No user data or credentials are exposed. The issue is fixed in versions 8.20.0, 9.25.0, and 10.12.0.

References

Community reviews

Loading reviews…