Skip to main content
CVE-2024-10979VulnerabilityPublished Updated

PostgreSQL PL/Perl · Incorrect Control of Environment Variables

Affects postgresqlSource GCVE Database

0
Compare
Authoritative record:CVE-2024-10979· High 8.8

Not known to be exploited · CVSS 8.8 High · fixed in 17.1 : patch postgresql soon.

Data as of 29 Oct 2026, 22:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.18.8
Patch
Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <17.1
  • <16.5
  • <15.9
  • <14.14
  • <13.17
  • <12.21
Fixed in
  • 17.1
  • 16.5
  • 15.9
  • 14.14
  • 13.17
  • 12.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in PostgreSQL versions 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21. Users should upgrade to these or later versions to remediate the issue. Since the vulnerability allows environment variable manipulation via PL/Perl, disabling or restricting the use of PL/Perl in environments where it is not needed can reduce exposure. No vendor advisory content was provided to indicate alternative mitigations or temporary fixes.

Description

A vulnerability in PostgreSQL PL/Perl allows unprivileged database users to modify sensitive process environment variables such as PATH. This flaw affects PostgreSQL versions prior to 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21. Exploiting this issue can enable arbitrary code execution without requiring operating system user privileges. The vulnerability has a high severity rating with a CVSS score of 8.8.

References

Community reviews

Loading reviews…