CVE-2024-12303: GitLab · Incorrect Privilege Assignment
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.2.2 : update gitlab when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.2.2, 18.1.4, 18.0.6
Exploitation evidence
Disclosed: evidence found.
CVE published 18 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade gitlab to 18.2.2, 18.1.4 or 18.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to versions 18.0.6 or later, 18.1.4 or later, and 18.2.2 or later as applicable to their installed version series to remediate this issue.
Description
A privilege assignment vulnerability in GitLab CE/EE versions from 17.7 up to but not including 18.0.6, 18.1 up to but not including 18.1.4, and 18.2 up to but not including 18.2.2 allows authenticated users with certain roles and permissions to delete issues, including confidential ones, by inviting users with a specific role.