Skip to main content
VulnerabilityPublished Updated

CVE-2024-10978: PostgreSQL · Incorrect Privilege Assignment

Affects postgresqlSource GCVE Database

0
Compare
Authoritative record:CVE-2024-10978· Medium 4.2

Not known to be exploited · CVSS 4.2 Medium · fixed in 17.1 : update postgresql when convenient.

Data as of 29 Oct 2026, 23:00 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.14.2
Patch
Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <12.21
  • <13.17
  • <14.14
  • <15.9
  • <16.5
  • <17.1
Fixed in
  • 12.21
  • 13.17
  • 14.14
  • 15.9
  • 16.5
  • 17.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21. Users should upgrade to these or later versions to remediate the vulnerability. No vendor advisory content contradicts this; therefore, upgrading is the recommended mitigation.

Description

CVE-2024-10978 is a privilege assignment vulnerability in PostgreSQL that allows a less-privileged application user to view or modify rows they should not access. This occurs when the application uses SET ROLE, SET SESSION AUTHORIZATION, or similar features, and queries react to current_setting('role') or the current user ID incorrectly. Versions prior to PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.

References

Community reviews

Loading reviews…