Skip to main content
VulnerabilityPublished Updated

CVE-2024-13041: GitLab · Incorrect User Management

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.7.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 11:42 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.7.1, 17.6.3, 17.5.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.7.1, 17.6.3 or 17.5.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.4.0 <17.5.5
  • >=17.6.0 <17.6.3
  • >=17.7.0 <17.7.1
Fixed in
  • 17.5.5
  • 17.6.3
  • 17.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to versions 17.5.5 or later, 17.6.3 or later, or 17.7.1 or later as appropriate. Applying these updates will correct the user management logic and prevent improper access. No additional mitigation steps are indicated beyond applying the official fix.

Description

GitLab CE/EE versions from 16.4 up to but not including 17.5.5, 17.6 up to 17.6.3, and 17.7 up to 17.7.1 contain a user management vulnerability. When users are created via the SAML provider, the external groups setting incorrectly overrides the external provider configuration. This flaw can cause users to be improperly marked as internal, granting them unintended access to internal projects or groups.

References

Community reviews

Loading reviews…