CVE-2026-55622: Incusd · Incus has a project restriction bypass in instance copy across projects
Affects github.com/lxc/incus/v7/cmd/incusdSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 7.2.0 soon.
Data as of 5 Nov 2026, 18:50 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.7 |
|---|
- Patch
- Available – fixed in 7.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade github.com/lxc/incus/v7/cmd/incusd and github.com/lxc/incus/v7 to 7.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/lxc/incus/v7/cmd/incusd | Affected
| Fixed in
|
| Gogithub.com/lxc/incus/v7 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Incusd to version 7.2.0 or later, where this authorization bypass vulnerability is fixed. No other mitigations are indicated or required as the issue is resolved by the official patch.
Description
CVE-2026-55622 is a vulnerability in Incusd (github.com/lxc/incus) prior to version 7.2.0 that allows an attacker to bypass project-level authorization checks when copying instances. An attacker who knows the name of a project and an instance within it, but lacks access permissions, can copy that instance to a project they control. This can lead to unauthorized access to secrets stored in the copied instances. The vulnerability exists because the source instance is loaded without verifying the caller's permission to view it. A proof-of-concept script demonstrates how to exploit this flaw. The issue is fixed in version 7.2.0.
References
- github.com/canonical/lxd/security/advisories/GHSA-qx75-2p3r-pwm5 (opens in a new tab)
- github.com/lxc/incus/security/advisories/GHSA-c9f5-j9c3-mhrg (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-55622 (opens in a new tab)
- github.com/lxc/incus/pull/3542 (opens in a new tab)
- github.com/lxc/incus/commit/1e3ffc53a10950e55de62ac1e0d612be597b84eb (opens in a new tab)
- discuss.linuxcontainers.org/t/incus-7-2-has-been-released/26879 (opens in a new tab)
- github.com/lxc/incus (opens in a new tab)
- github.com/lxc/incus/releases/tag/v7.2.0 (opens in a new tab)