Skip to main content
VulnerabilityPublished Updated

CVE-2025-24513: ingress-nginx controller - auth secret file path traversal vulnerability

Affects k8s.io/ingress-nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2025-24513· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.11.5 when convenient.

Data as of 30 Oct 2026, 16:04 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (kubernetes)CVSS 3.14.8
Patch
Available – fixed in 1.11.5, 1.12.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade k8s.io/ingress-nginx to 1.11.5; k8s.io/ingress-nginx to 1.12.1.

Affected software

ProductAffectedFixed in
Gok8s.io/ingress-nginxAffected
  • <1.11.5
Fixed in
  • 1.11.5
Gok8s.io/ingress-nginxAffected
  • >=1.12.0-beta.0 <1.12.1
Fixed in
  • 1.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading ingress-nginx to version 1.11.5 or later, or 1.12.1 or later for the affected beta versions. No additional mitigation steps are indicated by the vendor advisory. Users should prioritize updating to the fixed versions to remediate this vulnerability.

Description

A directory traversal vulnerability exists in the ingress-nginx Admission Controller where attacker-controlled data is used in a filename, potentially allowing denial of service or limited disclosure of Secret objects when combined with other vulnerabilities. This affects ingress-nginx versions prior to 1.11.5 and versions from 1.12.0-beta.0 up to but not including 1.12.1. The issue has been assigned CVE-2025-24513 and has a medium severity rating with a CVSS score of 4.8. Fixed versions 1.11.5 and 1.12.1 are available.

References

Community reviews

Loading reviews…