Skip to main content
VulnerabilityPublished Updated

CVE-2024-4472: Insertion of Sensitive Information into Log File in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.3.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.3.2, 17.2.5, 17.1.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.3.2, 17.2.5 or 17.1.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.5.0 <17.1.7
  • >=17.2.0 <17.2.5
  • >=17.3.0 <17.3.2
Fixed in
  • 17.1.7
  • 17.2.5
  • 17.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GitLab CE/EE to versions 17.1.7 or later, 17.2.5 or later, or 17.3.2 or later, as appropriate. This vulnerability is fixed in these versions. No additional mitigation is required once patched.

Description

A vulnerability in GitLab CE/EE allows dependency proxy credentials to be retained in GraphQL logs. This affects versions from 16.5 up to but not including 17.1.7, from 17.2 up to but not including 17.2.5, and from 17.3 up to but not including 17.3.2. The issue risks exposing sensitive credentials through log files.

References

Community reviews

Loading reviews…