CVE-2025-2615: Insertion of Sensitive Information Into Sent Data in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.5.2 : update gitlab when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.5.2, 18.4.4, 18.3.6
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.5.2, 18.4.4 or 18.3.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released in GitLab CE/EE versions 18.3.6, 18.4.4, and 18.5.2. Users should upgrade to these or later versions to remediate the vulnerability.
Description
A vulnerability in GitLab CE/EE versions from 16.7 up to but excluding 18.3.6, 18.4 up to but excluding 18.4.4, and 18.5 up to but excluding 18.5.2 could allow a blocked user to access sensitive information by establishing GraphQL subscriptions through WebSocket connections. This issue has been remediated in the specified fixed versions.