Skip to main content
CVE-2024-11931VulnerabilityPublished Updated

CVE-2024-11931: GitLab · Insufficient Granularity of Access Control

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.8.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 08:11 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.8.1, 17.7.3, 17.6.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 17.8.1, 17.7.3 or 17.6.4.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.0.0 <17.6.4
  • >=17.7.0 <17.7.3
  • >=17.8.0 <17.8.1
Fixed in
  • 17.6.4
  • 17.7.3
  • 17.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab CE/EE to versions 17.6.4, 17.7.3, or 17.8.1 or later where this vulnerability is patched. Refer to the official GitLab issue https://gitlab.com/gitlab-org/gitlab/-/issues/480901 for details. No other mitigation is indicated.

Description

GitLab CE/EE versions from 17.0 up to but not including 17.6.4, 17.7 up to 17.7.3, and 17.8 up to 17.8.1 contain an access control vulnerability. This flaw allows users with the developer role to potentially exfiltrate protected CI variables via the CI lint feature under certain conditions. A patch is available to address this issue.

References

Community reviews

Loading reviews…