CVE-2024-12619: GitLab · Insufficient Granularity of Access Control
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.10.1 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.10.1
Exploitation evidence
Disclosed: evidence found.
CVE published 1 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade gitlab to 17.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to version 17.8.6 or later for the 17.8 branch, 17.9.3 or later for the 17.9 branch, and 17.10.1 or later for the 17.10 branch to remediate this issue.
Description
GitLab CE/EE versions from 16.0 up to but not including 17.10.1 contain an access control vulnerability that allows internal users to gain unauthorized access to internal projects. This issue affects multiple version ranges and has been assigned CVE-2024-12619. A patch is available to address this vulnerability.