CVE-2025-1198: GitLab · Insufficient Session Expiration
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.8.2 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.8.2
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.8.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available for this vulnerability. Users should upgrade GitLab CE/EE to versions 17.6.5, 17.7.4, or 17.8.2 or later to remediate the issue. No additional mitigation steps are indicated beyond applying the official patches.
Description
GitLab CE/EE versions from 16.11 up to but not including 17.8.2 contain a vulnerability where long-lived ActionCable connections may allow revoked Personal Access Tokens to continue accessing streaming results. This is due to insufficient session expiration handling.