CVE-2025-12501: GameMaker IDE below · Integer Overflow
Source GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 2024.14.0 : patch GameMaker IDE soon.
Data as of 29 Oct 2026, 23:31 UTC
- Affects
- GameMaker IDE prior to 2024.14.0
- Patch
- Available – fixed in 2024.14.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
AI-suggested
Users should update to GameMaker IDE version 2024.14.0 or later and recompile their projects to remediate this vulnerability. Immediate update and recompilation is recommended to prevent denial-of-service.
Description
An integer overflow vulnerability exists in GameMaker IDE versions prior to 2024.14.0. This flaw can cause application crashes via denial-of-service (DoS) attacks when using the network_create_server() function. Users are advised to update and recompile their projects with the fixed version.