Skip to main content
VulnerabilityPublished Updated

CVE-2026-97229: GitLab · Integer Overflow or Wraparound

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-97229· Critical 10.0

Exploited in the wild · KEV due 1 Nov 2026 · fixed in 19.4.2 : patch gitlab now.

Data as of 30 Oct 2026, 12:21 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.110.0
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 19.4.2, 19.3.5, 19.2.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 16 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitLab Inc.

    , 19 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    exploitation active

    , 16 days after disclosure

  4. In Threat Radar

    record ingested

    , 16 days after disclosure

  5. , 16 days after disclosure

  6. KEV remediation due

    US federal deadline

    , 19 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gitlab to 19.4.2, 19.3.5 or 19.2.8.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=19.2.0 <19.2.8
  • >=19.3.0 <19.3.5
  • >=19.4.0 <19.4.2
Fixed in
  • 19.2.8
  • 19.3.5
  • 19.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

GitLab CE/EE versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 contain an integer overflow or wraparound vulnerability. This flaw allows an unauthenticated user to execute arbitrary code on the GitLab server by leveraging a specially crafted regular expression in a CI/CD configuration due to insufficient validation. The issue has been remediated in versions 19.2.8, 19.3.5, and 19.4.2.

References

Community reviews

Loading reviews…