Skip to main content
VulnerabilityPublished Updated

CVE-2024-11042: InvokeAI Arbitrary File Deletion vulnerability

Affects InvokeAISource GCVE Database

0
Authoritative record:CVE-2024-11042· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 5.3.0rc1 as a priority.

Data as of 27 Oct 2026, 18:30 UTC

CVSS 3.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.3.0rc1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade InvokeAI to 5.3.0rc1.

Affected software

ProductAffectedFixed in
PyPIInvokeAIAffected
  • <5.3.0rc1
Fixed in
  • 5.3.0rc1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade InvokeAI to version 5.3.0rc1 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

InvokeAI version prior to 5.3.0rc1 contains an arbitrary file deletion vulnerability in its web API endpoint POST /api/v1/images/delete. This flaw allows unauthorized attackers to delete arbitrary files on the server, including critical system files such as SSH keys, SQLite databases, and configuration files, impacting application integrity and availability. A patch is available in version 5.3.0rc1.

References

Community reviews

Loading reviews…